Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"0x0000009E" Stop error when you add an extra storage disk to a failover cluster in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a failover cluster on some computers that are running Windows Server 2008 R2.
  • The cluster has many disks.
  • You click Add a disk in the Failover Cluster Manager console to add an extra storage disk on one cluster node.
In this scenario, you receive a Stop error message that resembles the following after a while:
0x0000009E ( parameter1 , parameter2 , parameter3 , parameter4 )
USER_MODE_HEALTH_MONITOR
Notes
  • The parameters in this Stop error message may vary, depending on the configuration of the computer.
  • Not all "0x0000009E" Stop errors are caused by this issue.
Additionally, you may experience the following issues if a cluster has many disks. For example, the cluster has more than 200 hard disks.
  • The Cluster service takes a long time to start.
  • The failover or shutdown operation of cluster resources takes a long time to complete.
  • The operation that adds a new storage disk into the cluster takes a long time to complete.

↑ Back to the top


Cause

When you add extra disks on a cluster that has lots of disks, the thread pool in the Cluster service may be exhausted.

↑ Back to the top


Resolution

To resolve this issue, install the following hotfix on a computer that is running Windows Server 2008 R2. The following hotfix optimizes the hard disk resource implementation and improves the hard disk performance in a Windows Server 2008 R2 cluster.

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    20xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 " section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.1.7600.209211,277,44011-Mar-201106:16x64
Clusres.dll6.1.7601.216801,280,00011-Mar-201106:09x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.1.7600.209212,118,14411-Mar-201105:11IA-64
Clusres.dll6.1.7601.216802,121,72811-Mar-201105:07IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_4bf688d962cb4346d94bfa000aacc810_31bf3856ad364e35_6.1.7600.20921_none_4a8731e70a23f183.manifest
File versionNot applicable
File size715
Date (UTC)11-Mar-2011
Time (UTC)15:38
File nameAmd64_884a82c7173ec03e8690ae2ae96fee48_31bf3856ad364e35_6.1.7601.21680_none_23ac5e1fe9bc114f.manifest
File versionNot applicable
File size715
Date (UTC)11-Mar-2011
Time (UTC)15:38
File nameAmd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7600.20921_none_1d96157bcf9cd43a.manifest
File versionNot applicable
File size2,693
Date (UTC)11-Mar-2011
Time (UTC)07:10
File nameAmd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7601.21680_none_1f3a90c9ccf4d14e.manifest
File versionNot applicable
File size2,693
Date (UTC)11-Mar-2011
Time (UTC)06:42
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_3ae79de64a498b0f9c43e1639c0bb09f_31bf3856ad364e35_6.1.7601.21680_none_aed53e0f1d634760.manifest
File versionNot applicable
File size713
Date (UTC)11-Mar-2011
Time (UTC)15:38
File nameIa64_62b1931a4f533f10777905831e853888_31bf3856ad364e35_6.1.7600.20921_none_2f4c892cad41cd0e.manifest
File versionNot applicable
File size713
Date (UTC)11-Mar-2011
Time (UTC)15:38
File nameIa64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7600.20921_none_c1791dee173d6c00.manifest
File versionNot applicable
File size2,691
Date (UTC)11-Mar-2011
Time (UTC)07:15
File nameIa64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7601.21680_none_c31d993c14956914.manifest
File versionNot applicable
File size2,691
Date (UTC)11-Mar-2011
Time (UTC)06:42

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 2520235
Revision : 1
Created on : 1/7/2017
Published on : 5/24/2013
Exists online : False
Views : 272